Energy Price Cap announcement: Watch Martin Lewis explain what it means for your electricity and gas bills this winter

Free Santa letter and personalised video message discussion



  • Not working for me either!

    However, going to the site via Google is slightly different to the site via my favourites bar from last year - very subtle eg: "array" instead of "country" as one of the questions.

    Neither site will let me past the first page of information but something is definatley up....
  • Exactly the same with me. Got fooled into dowloading the ilivid thing, had to restore pc and then tried by just updating flash but still saying errors on the page.
  • bazza2000_2bazza2000_2 Forumite
    45 Posts
    Part of the Furniture 10 Posts Combo Breaker
    WARNING: The link on the top and right hand side of the page are adverts and are trying to fool you into downloading the ilivid software which isn't required for the santa video. The link for the flash update is at the bottom of the page if you scroll down.

    "Flash 9 Plug-in is required. You may download it here."

    You may already have the correct version of flash, you can confirm if on the main page you see the TV with "Santas has video message for you" overlaying a photo of Santa.

    After all this, I'm having problem too once I've filled in the 1st page of information out my child I hit Next but don't get to the next page, nothing happens, anyone else getting this?
  • Dark_StarDark_Star Forumite
    611 Posts
    Part of the Furniture 500 Posts Photogenic
    I did a couple on PNP which did work but now cannot get beyond the first page.

    I've now been using another one which is similar & very easy to use: If you do not have a photo then it inputs a cute snowman.:rotfl:
    Lurking in a galaxy far far away...
  • Same here, can't get the link to work, despite having downloaded ilivid and flash9!
    Can forum monitors help?
  • ladelaladela Forumite
    129 Posts
    My friend was having the same problem yet it worked on mine. I think the flash message is actually an ad (spyware) someone has put on there. If you use Google Chrome go to the 'Google web store' and download 'Adblock' for free then go to the PNP site through Chrome and it should work. Probably other adblock programs will work too but this way definitely works 'cos ive just done it on my friends pc. Hope that helps.
  • Thanks Ladela, that worked perfectly after hours of trying. I realised the downloads were spyware, but no way it would work before using Adblock - great tip!
  • Thank you Ladela - you have saved Christmas here!!!!

    Solved the problem, and will be worth it when my three get their messages back from FC x
  • booterbooter Forumite
    1.7K Posts
    Part of the Furniture 1,000 Posts Name Dropper Combo Breaker
    Thanks for the heads up Ladela - I didn't know if I could use adblock without Firefox or Google chrome, so I searched "adblock" on the forums and found this (thanks to maleman!) and it seemed to work. Many thanks to OP aswell!
  • daveyjpdaveyjp Forumite
    11.8K Posts
    Part of the Furniture 10,000 Posts Name Dropper
    PNP worked fine for me, parents had a problem with flash, but downloaded latest version and all OK.

    Just need to wait for daughter to see it tomorrow.
This discussion has been closed.
Latest MSE News and Guides

Energy Price Cap change

Martin Lewis on what it means for you

MSE News

Best £1 you've ever spent?

Share your most impressive bargains

MSE Forum