Search of main site never produces results

TheMidnightSkulker
TheMidnightSkulker Posts: 32
First Anniversary First Post Name Dropper Combo Breaker
Forumite
edited 4 July 2022 at 9:53AM in Site feedback
I notice that when I search the site on a term I would expect would get results ("hsbc") I get a yellow screen, an explanation of how the site works, but no actual results. Ever. Screenshot below.

It doesn't matter if I'm logged in or logged out. I'm using Brave, but switching browsers doesn't help.

I do get results if I search the forum, but not the main site.

I experienced this a few weeks ago and gave up. Now I try again, it's still happening.

Anyone else getting this?


Comments

  • MSE_James
    MSE_James Posts: 1,109
    First Post First Anniversary Cashback Cashier Newshound!
    Community Admin
    This is what I see for the same search:



    Are you using some kind of ad-blocking or other privacy plugin in the browsers (other than Brave) that you are trying?
    Official MSE Forum Team member.
    Please report all problem posts to [email protected]
  • MSE_James
    MSE_James Posts: 1,109
    First Post First Anniversary Cashback Cashier Newshound!
    Community Admin
    I've just installed Brave on my own machine and the MSE site search works for me - can you confirm that the problem still persists for you as of now?
    Official MSE Forum Team member.
    Please report all problem posts to [email protected]
  • heatherw_01
    heatherw_01 Posts: 6,521
    Name Dropper First Anniversary First Post Photogenic
    Ambassador
    Also a brave user and haven't had this issue myself.
    I’m a Forum Ambassador and I support the Forum Team on the Quick Grabbit, Freebies, Overseas Holidays & Travel Planning and the UK Holidays, Days Out & Entertainments boards.
    If you need any help on these boards, do let me know. Please note that Ambassadors are not moderators. Any posts you spot in breach of the Forum Rules should be reported via the report button, or by emailing [email protected].
    All views are my own and not the official line of MoneySavingExpert.
  • Hey, sorry, I got distracted shortly after posting this and now I realize I never followed up.

    After clearing history, I was able to get search results if and only if I was logged in. If I'm logged out I always get the blank yellow screen.

    I do use a VPN. If I turn it off the search results appear, whether or not I'm logged in.

    So that is the answer. For security reasons however, I'm not gonna turn the VPN off, so I'll just stay logged in every time I want to use the site.
Meet your Ambassadors

Categories

  • All Categories
  • 341.7K Banking & Borrowing
  • 249.7K Reduce Debt & Boost Income
  • 449.2K Spending & Discounts
  • 233.9K Work, Benefits & Business
  • 606K Mortgages, Homes & Bills
  • 172.5K Life & Family
  • 246.8K Travel & Transport
  • 1.5M Hobbies & Leisure
  • 15.8K Discuss & Feedback
  • 15.1K Coronavirus Support Boards