Application Firewall Error - 65% of posts mainly just text

mark55man
mark55man Posts: 7,924 Forumite
Name Dropper First Post First Anniversary
edited 31 December 2018 at 8:37AM in Site feedback
TL;DR - My requests to post keep getting blocked - I would send a screenshot but it keeps getting blocked

Problem
Every day about 2/3 of my mainly text posts get a pop up saying my request has been blocked

"if you feel you have been blocked in error please contact ...."

I contacted them a few days ago but no reply.

Analysis
To me it looks like you have a new web application firewall and for some reason I have got on the wrong side of it. As I am merely just posting text on this forum as I have always done, it is clear that you have not yet configured it properly and I would ask that you do so, as it is rendering the site unusable.

I now limit myself to really short replies (which may be a good thing in itself), but it is enormously frstrating to lose a long post, have to recover the text (not always possible) and then shut everything down and restart before I post "THE EXACT SAME POST" successfully

what are you trying to achieve with this innovation - its not working for me TBH
I think I saw you in an ice cream parlour
Drinking milk shakes, cold and long
Smiling and waving and looking so fine

Comments

  • mark55man
    mark55man Posts: 7,924 Forumite
    Name Dropper First Post First Anniversary
    Hello - is there anybody here? Still happening I've tried IE 11 and Latest Firefox - just randomly blanking and then losing posts. If you are going to show an error message you need to take more steps to preserve the text that was submitted - its all a bit Random - and in my book that;s the worst thing a website can be
    I think I saw you in an ice cream parlour
    Drinking milk shakes, cold and long
    Smiling and waving and looking so fine
  • mark55man
    mark55man Posts: 7,924 Forumite
    Name Dropper First Post First Anniversary
    And here's an odd one - if I post a youtube link its fine as long as I don't put http in front of it. Then you resolve this into an active clickable link, and then when I edit it and try to resubmit you block it. I think you need to look at what you are trying to protect yoruself from
    I think I saw you in an ice cream parlour
    Drinking milk shakes, cold and long
    Smiling and waving and looking so fine
  • mark55man
    mark55man Posts: 7,924 Forumite
    Name Dropper First Post First Anniversary
    Plus here's an odd one - sometimes it gives me the firewall block error but posts the message anyway

    MSE - your email to my report of this just blamed a rogue IP which is odd as it happens on more than one IP and shouldn't happen intermittently (sounds more like a convenient excuse). Tell me what do I have to do to get a proper response to this problem - you are not performing very well as a CSR or as a service desk - sorry to say it out loud
    I think I saw you in an ice cream parlour
    Drinking milk shakes, cold and long
    Smiling and waving and looking so fine
  • Hi. Thank you for letting us know.

    I realise you've been in touch with a team member already. If this is still happening could you email the link to this thread, together with screenshots of your error and mentioning we've asked you to get in touch to forumteam @ moneysavingexpert.com please?

    Thank you!
    Could you do with a Money Makeover?


    Follow MSE on other Social Media:
    MSE Facebook, MSE Twitter, MSE Deals Twitter, Instagram
    Join the MSE Forum
    Get the Free MoneySavingExpert Money Tips E-mail
    Report inappropriate posts: click the report button
    Point out a rate/product change
    Flag a news story: news@moneysavingexpert.com
  • mark55man
    mark55man Posts: 7,924 Forumite
    Name Dropper First Post First Anniversary
    edited 12 January 2019 at 12:08PM
    Its still happening - every time I post a http link - I just lost about 15 minutes typing on an update for my blog. even if you do have to put the blasted message in the way, you shold at least fail gracefully and return the user to the state so they can do something about it..

    Losing integrity of data submitted is a bit of a no no really - honestly - you need to have a word with your security team and check they know what they are doing, and that they have an understanding between what is actually a risk and what is just easy for them to do. I suggest they need some proper advice - because it doesn't come across as at all professional.

    Also - sorry - but I'm not going to join this up for you - its your problem you should send them the link - either I'm the only one with a problem in which case it will be easy to find, or many people are reporting this which means they should just get on with solving it

    very very annoyed user - but do you actually care?
    I think I saw you in an ice cream parlour
    Drinking milk shakes, cold and long
    Smiling and waving and looking so fine
  • mark55man
    mark55man Posts: 7,924 Forumite
    Name Dropper First Post First Anniversary
    Please explain this MSE Andrea

    I submit a post with a link in but which i have removed the hxxps from the beginning

    Your site then posts this and activates the link

    I spot an error and edit it but you software then rejects the post een though it was previously happy to have a link, and indeed you put the activiation on

    Not only that, but when you reject the edit, you also delete half the post above that had already been submitted

    And even worse, the previous version of this post in only contained the text hxxp colon slash slash and you rejected it

    Perhaps you should emply someone who understands security, UX and rigorous testing in your IT team

    fed up doing your job for you
    I think I saw you in an ice cream parlour
    Drinking milk shakes, cold and long
    Smiling and waving and looking so fine
This discussion has been closed.
Meet your Ambassadors

Categories

  • All Categories
  • 343.2K Banking & Borrowing
  • 250.1K Reduce Debt & Boost Income
  • 449.7K Spending & Discounts
  • 235.2K Work, Benefits & Business
  • 607.9K Mortgages, Homes & Bills
  • 173K Life & Family
  • 247.9K Travel & Transport
  • 1.5M Hobbies & Leisure
  • 15.9K Discuss & Feedback
  • 15.1K Coronavirus Support Boards