File sharing with wireless network

in Techie Stuff
13 replies 692 views
Hi

I am looking for any advice.

I have installed a netgear wireless router DG834G and can now access the internet wirelessly via my Laptop, which is great, but for some reason I cannot get the Laptop and PC to see one another.

I am now going in circles trying to sort it out.

My Laptop is on XP with SP2 and the PC is on ME.

I know there must be a way to do it and I suppose I could live without file sharing but I have got so far and would like to get my money's worth out of the router.

I have tried searching online for suggestions but to be honest they have got me quite confused.

If anybody has any hints I would love to hear them.

Thanks
Its better to be late in this life than early in the next one.

Slow down speed kills.
«1

Replies

  • Can both computers see each other if you ping them from a command window?

    Are any of them running a software firewall? Disable it if so.

    By default, XP uses the workgroup name MSHOME and ME uses the name WORKGROUP. Make sure both computers are using the same workgroup name.

    Have you run the Network Setup Wizard on the XP m/c? Control Panel - Network Connections.
  • JonnyF_2JonnyF_2 Forumite
    45 Posts
    If that doesn't work try this... I had a very similar problem with a friend a couple of days ago... (Sorry for the long post). If you can't 'ping' between the 2 computers, I think this is almost certainly the problem.

    I think the problem is by default your router stops the 2 computers from seeing each other by enabling a firewall between all the computers connected to the network. This is a good thing, because if it was being used in a public place it stops people sharing viruses with each other.

    If you load your browser, and go to http://192.168.0.1 from either computer, you will be asked a username and password. Log in as admin, with the password specified in your manual. (By default it's probably empty).

    You should now see a webpage showing the settings for your router. If you go to the firewall section, you should be able to specify the settings. I don't know what the options are for your router, but there should be a way of allowing traffic to and from a range of IP addresses.

    All the IP addresses on your local network will be in the range 192.168.0.x where x is a number between 1 and 255. You need to allow all traffic from this range to go to computers on this range again. For example:
    Allow
    Traffic from IP range 192.168.0.1 to 192.168.0.255 access to Traffic from IP range 192.168.0.1 to 192.168.0.255

    For testing purposes, you may like to take off the firewalls on both computers. (Or at least make sure the Windows XP firewall is configured to allow "File and Printer Sharing"). You should be perfectly safe without your computer's firewall because your router acts as a firewall too!

    When you've done that, go to My Network Places, then View Workgroup Computers. (Make sure you know which workgroup both computers are on - preferably the same workgroup). You should be able to see both computers in there now!

    Sorry for a long, complicated post, but it's quite a difficult issue to explain! Let me know if you need any more information!

    Jonny
  • Try re-running the Network Set-up Wizard on the XP laptop and at the end select 'Create Set-up Disk.'

    Then run the set-up disk on the ME machine.

    :cool:

    TOG
    604!
  • mjenn5mjenn5 Forumite
    556 Posts
    Thank you for your suggestions.

    Each computer can see itself but not each other.

    They both have the same workgroup name.

    I have allowed the range of ip addresses in the router setup page.

    If I turn off the firewall on each computer then I can ping the different ip addresses but still cannot see the other machine.

    When I turn it back on again I can no longer ping the other machine though I have allowed exceptions.

    I have tried running the network setup programs but can't seem to get the setup disc to work on the ME machine.

    I am not sure where in the ME computer to manually put the wireless settings (key etc) but they are correct on the router.

    Trying all of these does not seem to get the computers to see one another.


    I appreciate any help that can be given.
    Its better to be late in this life than early in the next one.

    Slow down speed kills.
  • mjenn5 wrote:
    I am not sure where in the ME computer to manually put the wireless settings (key etc) but they are correct on the router.

    Ah - I think I missed something crucial from your first post. Have you actually managed to connect to the internet from the ME computer? Can you ping the router (192.168.0.1) from the ME computer? Can you ping the laptop?

    How is the ME computer connected to the network, are you using an ethernet cable, usb into the router, or are you using a wireless device?

    Jonny
  • HLKHLK Forumite
    978 Posts
    What settings have you for a) wireless settings - security encription are you using WEP?

    What does it say in 'Attached devices'?

    Is there anything in 'Advanced Wireless Settings' - Setup Access list ?
    HLK

    "Karma - it's a wonderful thing" - Just ask Earl!
  • mjenn5mjenn5 Forumite
    556 Posts
    I can connect to the internet from both XP laptop and ME computer using the router.

    I can ping the router from both machines. I can only ping the laptop from the pc when firewall is off all together.

    The ME pc is connected via an ethernet cable to the router.

    The security is set a WEP with the key set up. I have ticked the enable wireless access point and the mode is set to G + B.

    Under attached devices I have 1 the PC and 2 another Unkown device with the correct ip address for my laptop

    Access control is ticked and the laptop is listed under the trusted wireless stations
    Its better to be late in this life than early in the next one.

    Slow down speed kills.
  • I would turn off WEP security, wireless access control, firewall etc. until you get it all working.

    See the section on Setting up TCP/IP for setting up file and printer sharing on your ME m/c.
  • wolfmanwolfman Forumite
    3.2K Posts
    When you say "see" what do you mean? How are you trying to see the other machine? By name or ip?

    If you're trying to go through "My Network Places" or using "\\ComputerName" then it may be a dns issue.

    On each machine, got to Start > Run > type "cmd". A command prompt will appear, type "ipconfig" and press enter. Note down the IP address of each machine, then simply open up a Windows Explorer window and type in the address bar type "\\ipaddress", (ie "\\192.168.0.4") where ipaddress is the address of the other machine. See if that works.

    Local ip address can be on any of the following ranges:
    10.xxx.xxx.xxx
    192.168.xxx.xxx
    172.16.xxx.xxx - 172.31.xxx.xxx
    By default you usually find routers are either set with 192.168.0.1 or 10.0.0.1 as their address

    DON'T use the Wizards in Windows. They just cause problems. Either set the network settings manually in Windows, or let your Router do the assigning via DHCP. I wouldn't turn off WEP, or the firewall etc... as both machines are being accepted by the router, it's just a case that they can't see each other.

    If you can ping both machines, then something is working. That's why I've suggested trying to access the machine via ip. If that doesn't work then it may be down to permissions, but you should at least get a response if that is the case.
    "Boonowa tweepi, ha, ha."
  • mjenn5mjenn5 Forumite
    556 Posts
    Well

    I have an update for you.

    I have been fideling around with this for so long and in so many different ways.

    I now at the moment have some sort of success.

    I can see the other computers in the network and from the ME PC I can access both of them yipee.

    From the XP Laptop I click on the PC icon and I get this message " is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions. The network path was not found."

    I hope this connection remains as I have got and lost it once before but not both ways.

    Does anybody know what I need to do about the permissions to use the PC.

    I really need the laptop to see the pc as this is where my printer etc is stored.
    Its better to be late in this life than early in the next one.

    Slow down speed kills.
This discussion has been closed.
Latest MSE News and Guides

Check your Clubcard vouchers

Use our trick to extend them

MSE News

Preparing for summer

What MoneySaving things can you do now to get ready?

MSE Forum

Hot Diamonds 40% off code

Including already-reduced outlet stock

MSE Deals