EE mobile account access fault (Unresolved)

I moved over to EE from Plusnet a couple of months ago (sim only). In that time, I've never been able to access my EE account, despite numerous communications with EE support and an escalation to the 'specialist technical team'. I'd be interested to know if anyone else has had this problem or experienced EE's inability to resolve technical faults. This is the error message returned when I try to log in via the website or app:



Comments

  • forgotmyname
    forgotmyname Posts: 32,481
    First Anniversary Name Dropper First Post
    Forumite
    My phone still says Plusnet/EE.  Tried logging into the Plusnet account?

    I created an EE account as soon as I was done on the phone with the Plusnet guy.  Shame the other users on my account cannot get their
    own minutes/data usage. 

    Tried adding a 2nd name and it said only the account holder can access it.   So I have gone from 4 separate accounts on Plusnet all under
    my name with different emails and passwords because they said they cannot merge them to EE where it's all on one account but the other
    users cannot see their allowance or usage.

    Seems I cannot win.

    Just logged into my EE account and it's all working.  What URL are you using and did you create an account yet? 
    Try a different browser.

    Censorship Reigns Supreme in Troll City...

  • [...] What URL are you using and did you create an account yet? 
    Try a different browser.

    I created an account within a week of activating the SIM and EE actioning the port-in request.

    Early on, I tried the various obvious ways of logging in...

    (1) via the website (ee.co.uk) on two different Windows laptops and two different Android devices using various browsers (Chrome/Firefox/Edge);

    (2) via the Android app on my mobile (Android 11) and tablet (Android 10).

    Both website and app account access is actioned via a redirect to auth.ee.co.uk and it's there that the error message pops up.

    Just in case the fault is IP or ISP related, I've attempted to log in both at home and at work.

    EE's technical team acknowledged early on that the problem was with their systems.

    I've spoken/messaged with 10 different EE staff over 8 weeks.

    EE have proved that they are unwilling/unable/unavailable to fix this fault - So much for their self-proclaimed "commitment to excellence"!

    UPDATE - I've just moved to Lebara.

Meet your Ambassadors

Categories

  • All Categories
  • 341.7K Banking & Borrowing
  • 249.7K Reduce Debt & Boost Income
  • 449K Spending & Discounts
  • 233.8K Work, Benefits & Business
  • 606K Mortgages, Homes & Bills
  • 172.4K Life & Family
  • 246.5K Travel & Transport
  • 1.5M Hobbies & Leisure
  • 15.8K Discuss & Feedback
  • 15.1K Coronavirus Support Boards