Applying For Probate Online - Technical Problems

I applied for Probate on Monday and the application went through fine.   

I paid the online fee at the end and received an email saying my payment had been successful. 

However, I then expected to click through to a different page on the website advising me what documents to send and with a coversheet etc and to receive maybe an email from them (I didn't know what to expect).  However, instead it went back to the screen saying Pay and Submit Application, where it is now permanently stuck.  Also, on the probate application page, the matter still said 'In Progress' in yellow.

I have called them 4 times this week and eventually spoke to someone in accounts who has married up my payment reference number with the Case ID Number and the status has gone from being 'In Progress' in yellow to being 'Sent' in green (although the other screen still says Pay and Submit Application.

Every time I've spoken to the Probate office they have just told me to send the documents in anyway.  I have made up my own coversheet and have found the address to send the documents to.  I just hope they are able to access my online application from their end.

The process has seemed fairly straight forward, apart from this technical glitch which has put my stress levels through the roof.  I gather others have had similar issues one way or an other.
Meet your Ambassadors

Categories

  • All Categories
  • 341.8K Banking & Borrowing
  • 249.7K Reduce Debt & Boost Income
  • 449.2K Spending & Discounts
  • 233.9K Work, Benefits & Business
  • 606.1K Mortgages, Homes & Bills
  • 172.5K Life & Family
  • 246.8K Travel & Transport
  • 1.5M Hobbies & Leisure
  • 15.8K Discuss & Feedback
  • 15.1K Coronavirus Support Boards