Forum Home» Phones & TV

Humax Freesat 1010S Tuners

New Post Advanced Search

Humax Freesat 1010S Tuners

edited 9 June at 9:25PM in Phones & TV
4 replies 51 views
evenasusevenasus Forumite
11.9K posts
Part of the Furniture 10,000 Posts Name Dropper
✭✭✭✭✭
edited 9 June at 9:25PM in Phones & TV
I've just bought a Humax Freesat 1010S and not sure if both tuners are working.
On our old Humax Foxsat both signals had % showing on each.
On this 1010S it only 'looks' like one is working as only tuner one has the 100% sign.
It also says Freesat box connected with one cable but it does have two connected, as did the old Humax Foxsat it replaced.
Does anyone have one of these boxes or knows about the signal indicators?
The time for saving for a house deposit, is before you marry/live together/have children.
Save for what you want to buy
.

You're - You are
Your - It's yours.

Replies

  • neilmclneilmcl Forumite
    16K posts
    Tenth Anniversary 10,000 Posts Name Dropper
    ✭✭✭✭✭
    Try reconnecting the cables and make sure that the wire on the F connector is fully going in to the socket and not been bent.
  • almillaralmillar Forumite
    8.6K posts
    Part of the Furniture 1,000 Posts Photogenic Name Dropper
    ✭✭✭✭
    Looks very clear to me that only 1 tuner is reporting a signal. Start at the back of the box, work out which cable the problem is with, and find the problem. It's much more likely to be a cable issue than a tuner issue. If you've just installed it, you could have damaged the (very easily damaged!) F-connector. Make sure the core isn't shorting with the shielding, for example. Swap the cables round the different tuners. If I'm right about the cable, your screen should show a good signal at tuner 2 and nothing at tuner 1.
  • evenasusevenasus Forumite
    11.9K posts
    Part of the Furniture 10,000 Posts Name Dropper
    ✭✭✭✭✭
    Did try switching the leads last night but still only one showing working.

    More Googling this morning brought up a post from someone on another forum, saying that the box was probably originally installed by the previous owner with only one feed.
    Decided to put back to factory settings and reinstall. Bingo! Both feeds working now. 
    The time for saving for a house deposit, is before you marry/live together/have children.
    Save for what you want to buy
    .

    You're - You are
    Your - It's yours.
  • almillaralmillar Forumite
    8.6K posts
    Part of the Furniture 1,000 Posts Photogenic Name Dropper
    ✭✭✭✭
    Great - that's an easy fix!
Sign In or Register to comment.

Quick links

Essential Money | Who & Where are you? | Work & Benefits | Household and travel | Shopping & Freebies | About MSE | The MoneySavers Arms | Covid-19 & Coronavirus Support