4Tb drive showing as 2Tb

in Techie Stuff
3 replies 677 views
Ant555Ant555 Forumite
1.5K Posts
Ninth Anniversary 1,000 Posts Photogenic Name Dropper
Forumite
I have a 4Tb desktop HD that is only showing as 2Tb. and am looking for a general direction on how to fix.

The scenario is that I actually have two 4Tb 'data' drives (a WD Green and a WD Red) so I am happy the BIOS and drivers are OK and 4Tb capable as both were working last week.

The 4Tb Red works fine either attached to the motherboard or as an external USB in a 'toaster' device.

The 4Tb Green disappeared from Windows 7 last week and I have lost data but when I tried to reformat it only shows as 2Tb. Have tried both attached to motherboard and also in the toaster but only seen as 2Tb.

Anyone have any tricks/hacks on how I can reformat this disk back to 4Tb?
Thanks

Replies

This discussion has been closed.
Latest MSE News and Guides

Boost your Nectar points

Get up to £25 in bonus points

MSE News

Ask an Expert: Scams

Watch MSE Katie's answers to your questions

MSE Forum

Hot Diamonds 40% off code

Including already-reduced outlet stock

MSE Deals