problem with iboost+

My iboost has stopped heating water again, just says "water hot" all the time.
I have changed the immersion thermostat to no effect and I had this last year and they changed the iboost.
Any one got any ideas?. They are not responding to my emails.
4kWp, South facing, 16 x phono solar panels, Solis inverter, Lincolnshire.

Replies

  • EricMearsEricMears Forumite
    2.9K Posts
    Part of the Furniture 1,000 Posts Name Dropper
    ✭✭✭✭
    ajbell wrote: »
    My iboost has stopped heating water again, just says "water hot" all the time.
    I have changed the immersion thermostat to no effect and I had this last year and they changed the iboost.
    Any one got any ideas?. They are not responding to my emails.
    Did fitting a new iboost unit last year cure the problem ? If it did but has gone wrong again then the new unit has probably developed the same fault as the old one. If changing it made no difference then you've probably got a thermostat fault on the immersion heater itself. Have you retained a facility to connect immersion heater directly to mains and if so does it work normally when connected thus or not ?
    NE Derbyshire.
    4kWp S Facing 17.5deg slope (dormer roof).
    BEV : Nissan Leaf e+
  • legoman62legoman62 Forumite
    3.7K Posts
    Tenth Anniversary 1,000 Posts Name Dropper
    ✭✭✭✭
    ajbell wrote: »
    My iboost has stopped heating water again, just says "water hot" all the time.
    I have changed the immersion thermostat to no effect and I had this last year and they changed the iboost.
    Any one got any ideas?. They are not responding to my emails.

    Have you got a reset button on your immersion?:D
    16 Sanyo Hit 250s.4kWp SMA 3.8kWp inverter. SW roof. 28° pitch.
    Minimal shade. Nov 2011 install. Hybrid car. N.E Lincs Coast.
  • ajbellajbell Forumite
    1.2K Posts
    ✭✭✭
    Looks like a fault on the iboost.
    4kWp, South facing, 16 x phono solar panels, Solis inverter, Lincolnshire.
  • pinnkspinnks Forumite
    840 Posts
    Sixth Anniversary 500 Posts Photogenic Rampant Recycler
    ✭✭✭
    Another test you could you is to plug something appropriate into the second output and direct the unit to use only output two (I assume iBoost works in a similar way to the immerSUN in this regard).

    If that is dead too then your iBoost has gone pop but if not the problem could be either immersion or iBoost...
    Wiltshire - 5.25kWp
    3.5kWp: 14 x Phono Solar 250 Onyx, Sunny Boy 4000TL, WSW 40 degrees, June 2013
    1.75kWp: 7 x Phono Solar 250 Onyx, Sunny Boy 1600TL, SSE 45 degrees, March 2014
This discussion has been closed.
Latest MSE News and Guides