Your browser isn't supported
It looks like you're using an old web browser. To get the most out of the site and to ensure guides display correctly, we suggest upgrading your browser now. Download the latest:

Welcome to the MSE Forums

We're home to a fantastic community of MoneySavers but anyone can post. Please exercise caution & report spam, illegal, offensive or libellous posts/messages: click "report" or email forumteam@.

Search
  • FIRST POST
    • ajbell
    • By ajbell 17th May 18, 9:26 AM
    • 977Posts
    • 3,139Thanks
    ajbell
    iboost problem
    • #1
    • 17th May 18, 9:26 AM
    iboost problem 17th May 18 at 9:26 AM
    Already on my third unit in 2.5 years and now it just says "water hot" all the time.
    Got a new thermostat on order as it may be that but any other ideas?
    4kWp, South facing, 16 x phono solar panels, Solis inverter, Lincolnshire.
Page 1
    • Dave Fowler
    • By Dave Fowler 17th May 18, 10:19 AM
    • 469 Posts
    • 831 Thanks
    Dave Fowler
    • #2
    • 17th May 18, 10:19 AM
    • #2
    • 17th May 18, 10:19 AM
    Already on my third unit in 2.5 years and now it just says "water hot" all the time.
    Got a new thermostat on order as it may be that but any other ideas?
    Originally posted by ajbell
    Could be open circuit immersion element. Are you able to check the voltage arriving at the immersion heater? - mine is plugged in to a 13 amp socket, so I can unplug it and connect a lamp or a heater.


    Dave F
    Solar PV System 1: 2.96kWp South+8 degrees. Roof 38 degrees. 'Normal' system
    Solar PV System 2: 3.00kWp South-4 degrees. Roof 28 degrees. SolarEdge system
    EV car
    Location: Bedfordshire
    • ChopperST
    • By ChopperST 17th May 18, 11:10 AM
    • 1,109 Posts
    • 742 Thanks
    ChopperST
    • #3
    • 17th May 18, 11:10 AM
    • #3
    • 17th May 18, 11:10 AM
    Could be open circuit immersion element. Are you able to check the voltage arriving at the immersion heater? - mine is plugged in to a 13 amp socket, so I can unplug it and connect a lamp or a heater.


    Dave F
    Originally posted by Dave Fowler
    Had my immersion element fail within one month of my immersun being installed. Had it replaced for a much more durable one as my the one in my tank was designed to only be used as a back up if the gas boiler failed. No problems since.

    I also had the water hot message on the unit.
    • ajbell
    • By ajbell 17th May 18, 8:02 PM
    • 977 Posts
    • 3,139 Thanks
    ajbell
    • #4
    • 17th May 18, 8:02 PM
    • #4
    • 17th May 18, 8:02 PM
    It was the Thermostat, all up and running again.
    4kWp, South facing, 16 x phono solar panels, Solis inverter, Lincolnshire.
    • silverwhistle
    • By silverwhistle 17th May 18, 8:41 PM
    • 1,833 Posts
    • 2,403 Thanks
    silverwhistle
    • #5
    • 17th May 18, 8:41 PM
    • #5
    • 17th May 18, 8:41 PM
    Glad you've sorted it. I can now joke that with the weather we've had the last couple of days 'course it's going to be HOT! Touch wood I've had mine nigh on 5 years with no problems apart from remembering how hot my hot tap can be!
Welcome to our new Forum!

Our aim is to save you money quickly and easily. We hope you like it!

Forum Team Contact us

Live Stats

61Posts Today

2,789Users online

Martin's Twitter
  • It's the start of mini MSE's half term. In order to be the best daddy possible, Im stopping work and going off line? https://t.co/kwjvtd75YU

  • RT @shellsince1982: @MartinSLewis thanx to your email I have just saved myself £222 by taking a SIM only deal for £7.50 a month and keeping?

  • Today's Friday twitter poll: An important question, building on yesterday's important discussions: Which is the best bit of the pizza...

  • Follow Martin