Your browser isn't supported
It looks like you're using an old web browser. To get the most out of the site and to ensure guides display correctly, we suggest upgrading your browser now. Download the latest:

Welcome to the MSE Forums

We're home to a fantastic community of MoneySavers but anyone can post. Please exercise caution & report spam, illegal, offensive or libellous posts/messages: click "report" or email forumteam@.

Search
  • FIRST POST
    • jjlothin
    • By jjlothin 29th Nov 18, 4:56 PM
    • 163Posts
    • 12Thanks
    jjlothin
    Can't access Cheap Energy Club comparison?
    • #1
    • 29th Nov 18, 4:56 PM
    Can't access Cheap Energy Club comparison? 29th Nov 18 at 4:56 PM
    I'm not sure if this is the best place to post but I've been trying to access my comparison on Cheap Energy Club for a couple of days now, and the site just whirs and whirs and whirs ... with no result. Have tried on a couple of different browsers.


    If anyone can advise, it would be most appreciated!
Page 1
    • stevejland
    • By stevejland 11th Jan 19, 4:55 PM
    • 38 Posts
    • 21 Thanks
    stevejland
    • #2
    • 11th Jan 19, 4:55 PM
    • #2
    • 11th Jan 19, 4:55 PM
    Same problem for me, any ideas?.

    Regards
    SJL
    • gsmlnx
    • By gsmlnx 11th Jan 19, 5:17 PM
    • 1,408 Posts
    • 1,030 Thanks
    gsmlnx
    • #3
    • 11th Jan 19, 5:17 PM
    • #3
    • 11th Jan 19, 5:17 PM
    if this URL fails https://clubs.moneysavingexpert.com/cheapenergyclub/login then got into your browser history and delete all references to moneysavingexpert.com . Also see if you can delete the cookies associated with the Cheap Energy Club.
    It is an issue with either your ISP, your browser or you are using a bad link.
    I've had no issues logging in this week and today so if there was a wide spread problem, then this forum would be inundated with complaints.
    • AuntyDom
    • By AuntyDom 16th Jan 19, 1:37 PM
    • 2 Posts
    • 0 Thanks
    AuntyDom
    • #4
    • 16th Jan 19, 1:37 PM
    • #4
    • 16th Jan 19, 1:37 PM
    In my case, it was simply because my 'current' tariff (in my settings) was blank - when I populated it, it worked fine
Welcome to our new Forum!

Our aim is to save you money quickly and easily. We hope you like it!

Forum Team Contact us

Live Stats

4,198Posts Today

8,016Users online

Martin's Twitter
  • 10 ways you should act now to beat April bill shocks - council tax UP, stamp prices UP, TV licence UP, energy bills? https://t.co/WiOWiogCCA

  • I have a confession to make... I think I now prefer Young Sheldon to The Big Bang Theory (or at least to the recent series). Am I alone?

  • RT @TDHPhotography: Thank you @MartinSLewis After seeing your show on Council tax exemption for severe mental disorders, after a brief batt?

  • Follow Martin