Anyone had any issues linking their bank account to Chip?

Old open banking connection expired but it wouldn't let me relink.  I click to relink and it just shows me the "you are connected" splash screen.  Doesn't attempt to have me authorize.  Shows no account linked.

I tried everything I can think of.  Different phone, reinstalling the app and the banking app (halifax), clearing out any old open banking permissions.  Nothing.

I contacted chat but they are taking almost a day to reply to every post at the moment.  Took two days for them to even talk to me as they wanted photos of ID and a selfie.  They then cleared all the old banking info so I could try adding it fresh - same issue.

I thought I might as well ask on here while I wait another day for them to get back to me withy any ideas.

thanks

Comments

  • alternate
    alternate Posts: 694
    Name Dropper First Post First Anniversary Combo Breaker
    Forumite
    As a follow up to this, in case it helps anyone, CS did finally solve the issue.  They were competent but very slow in replying to each post.  Whole thing took about 5 days, including the weekend, which they don't appear to work.  Luckily it wasn't an urgent problem.
Meet your Ambassadors

Categories

  • All Categories
  • 341.6K Banking & Borrowing
  • 249.7K Reduce Debt & Boost Income
  • 449.1K Spending & Discounts
  • 233.6K Work, Benefits & Business
  • 605.6K Mortgages, Homes & Bills
  • 172.3K Life & Family
  • 246.5K Travel & Transport
  • 1.5M Hobbies & Leisure
  • 15.8K Discuss & Feedback
  • 15.1K Coronavirus Support Boards