Your browser isn't supported
It looks like you're using an old web browser. To get the most out of the site and to ensure guides display correctly, we suggest upgrading your browser now. Download the latest:

Welcome to the MSE Forums

We're home to a fantastic community of MoneySavers but anyone can post. Please exercise caution & report spam, illegal, offensive or libellous posts/messages: click "report" or email forumteam@. Skimlinks & other affiliated links are turned on

Search
  • FIRST POST
    • georgiac
    • By georgiac 10th Mar 17, 5:49 PM
    • 1,103Posts
    • 502Thanks
    georgiac
    Windows10 PC can't see my phones?!
    • #1
    • 10th Mar 17, 5:49 PM
    Windows10 PC can't see my phones?! 10th Mar 17 at 5:49 PM
    Hi, I am trying to connect my mobile phones to my windows 10 PC but it isn't working.

    It will charge the phones fine but they don't show up in the directory like other exteranl hdd's do.

    I have got usb debugging turned on but that didn't help.

    It seems to only be a problem with the pc as if I connect to the laptop it works fine with the same cable.

    I downloaded a programme called Wondreshare MobileGo and that detected the phone and allowed me to transfer data but it cost £30 and I think I should beable to connect without that.

    Any help appreciated please.

    Thanks
Page 1
    • wongataa
    • By wongataa 10th Mar 17, 8:21 PM
    • 1,007 Posts
    • 541 Thanks
    wongataa
    • #2
    • 10th Mar 17, 8:21 PM
    • #2
    • 10th Mar 17, 8:21 PM
    Are they Android phones? Is so plug them into the computer, unlock them, and then swipe down from the notification bar to choose the USB option. Choose MPT to see the phone on the computer and be able to transfer files.
    • georgiac
    • By georgiac 10th Mar 17, 8:26 PM
    • 1,103 Posts
    • 502 Thanks
    georgiac
    • #3
    • 10th Mar 17, 8:26 PM
    • #3
    • 10th Mar 17, 8:26 PM
    Are they Android phones? Is so plug them into the computer, unlock them, and then swipe down from the notification bar to choose the USB option. Choose MPT to see the phone on the computer and be able to transfer files.
    Originally posted by wongataa
    Thanks, they are set to Media Device ( MTP) and work fine on my laptop. It must be a setting I have altered on the pc
    • dipsomaniac
    • By dipsomaniac 11th Mar 17, 8:13 AM
    • 5,520 Posts
    • 2,087 Thanks
    dipsomaniac
    • #4
    • 11th Mar 17, 8:13 AM
    • #4
    • 11th Mar 17, 8:13 AM
    when you connect to pc win10 should search for and install drivers for phone. it can take a couple of mins if it hasn't auto installed you will have to do a manual search for drivers and install
    Last edited by dipsomaniac; 11-03-2017 at 8:16 AM.
    "The Holy Writ of Gloucester Rugby Club demands: first, that the forwards shall win the ball; second, that the forwards shall keep the ball; and third, the backs shall buy the beer." - Doug Ibbotson
Welcome to our new Forum!

Our aim is to save you money quickly and easily. We hope you like it!

Forum Team Contact us

Live Stats

5,617Posts Today

5,269Users online

Martin's Twitter
  • Byebye! I'm about to stop work & twitter, to instead spend glorious time with Mrs & mini MSE. Wishing u a lovely summer. See u in 10 days.

  • WARNING Did you start Uni in or after 2012? The interest's rising to 6.1%; yet it doesnt work like you think. See https://t.co/IQ8f0Vyetu RT

  • RT @JanaBeee: @MartinSLewis Boris is the anomaly (coffee), the others are versions of normal (beer). Lots of same candidates = vote share d?

  • Follow Martin